[Fixed] “Server error” on forums?


(James McMahon) #1

“Internal Server Error” Message should now be resolved.

Let me know if you encounter this issue…


(James McMahon) #2

(Tony Zambos) #3

Haven’t experienced any server errors. But have found that clicking the symbol consisting of three horizontal lines located at the top right of the page only refreshes the current page and does not display the list of topics. Sometimes it works and sometimes it doesn’t.


(James McMahon) #4

Do you mean this?

It shouldn’t refresh the page, just display a menu.


(Andy Kutscher) #5

I tried to post a new post for several days late in the week last week and got the internal server error every time. Gave up eventually.

edit my draft was still out there this morning and I’m still getting the same message trying to post it.


(James McMahon) #6

Thanks Andy. Yeah it seems like it’ll save drafts from what people have described.


(Tony Zambos) #7

James, that’s exactly what I meant. But I knew as soon as I said something that the issue would disappear.


(James McMahon) #8

Odd, I don’t think it’s meant to refresh the page. Maybe the notifications area/


(James McMahon) #9

tl;dr, things should be better now

PSA: Found some things holding up the show on the server after heavy traffic.
Rebooted it, because of course you do.
Reviewing server config to see if tweaks are needed.


(Joseph Costanza) #10

Yes! I’m new here, been trying to introduce myself and get some advice and from both my phone and desktop I get that message and I am unable to post :frowning:


(Andy Kutscher) #11

tried to post mine again. Deleted and opened another new thread and still got the same error.


(Liam Sergeant) #12

Yes, I definitely had that issue. It also gave me the internal server issue when I tried to message you about it.

I did manage to reply to a topic without issue but I couldn’t do any more than that so gave up.


(James McMahon) #13

Thanks guys. Sorry things aren’t working as they should… Back to the drawing board. I suspect it’s related to the last update

@JCostanza welcome! I started a new topic for you since everything seems to be working for me so far. I made a few assumptions on the topic and category, go ahead and edit as you see fit.


(James McMahon) #14

Thanks for reporting this guys. I put a fix in place and we should be good to go…
Details below if that’s your jam


It’s a bug in the software we use (Discourse) from that last update and has since been fixed.
I’ll put the fix in place this evening as it takes the forums down for a while… about 30mins…
Since nobody except admins could post, I ran the update just now…

Nerdy info on the bug


(Andy Kutscher) #15

works like a charm now, thanks for the fix!


(James McMahon) #16

(Dom Callan) #17

Yep same here. Thanks