Engine Cranks But Doesn't Start

I tried turning on my engine today, it started cranking but wasn’t starting. I realized fuel wasn’t getting through and the battery cable became extremely hot. Any ideas what can be the issue? Fuel pump maybe?

1 Like

What motor would be a good start if info. Since you’re talking of battery start you’re not talking 206 or the like.

Yeah, I’m a little confused too. Sounds like we’re talking about a car…

I think he’s talking about a Suter Vampire.

Battery cable getting very hot might just be from a lot of attempts to start it. But if it’s got an electric fuel pump you might be on the right track on it failing.

1 Like

Jumper the fuel pump directly from a battery source. See if it draws fuel. If not likely a dead pump. If it does a relay might be your culprit

Yeah, its the Suter Vampire VT250, it’s not an electric pump, it works with the compression of the engine, so i’m worried it might need a top end rebuild. I will need to buy a compression tester to see if that is the problem

Obviously the carburettor float chamber needs to be full.
Try blowing down the vent pipe at the fuel tank to pressurise the tank a bit.
You can check for fuel supply at the carb by slackening the 6mm bolt holding the connector.
Dellorto carbs usually have a ‘choke’ lever for starting.
Filter off and a hand over the carb inlet might encourage it to start, and stop it if need be.
Poor/dirty connections starter to solenoid and to earth can cause the cables to overheat as can inadequate cable size
P.S Think you will find it uses a normal pulse pump which works off pressure pulses from the engine crankcase, but not from compression in the cylinder. A compression test on the engine would be useful but a sub optimal reading will not stop the pump working.

I tried all of the tips you gave but it doesn’t seem to start, the fuel still isn’t travelling trough the fuel lines. Could it be some air in the lines?

If you have disconnected the fuel feed at the carburettor by removing the 6mm bolt and fitting and can’t get fuel through by pressurising the tank as suggested then you must have a blockage somewhere or the pickup pipe in the tank is not into the fuel . Air in the line will not stop fuel flow.
Try blowing a bit harder into the tank with all outlets other than the feed to the pump sealed. You should be able to feel you are pressurising the tank.
Also blow back down the fuel pickup pipe into the tank to ensure the pickup is in the fuel and is clear.
If you can get flow through to the carb by pressurising the tank you may still find the pump may not pump fuel due to suction air leaks into the lines . Check if the lines have hardened and if so replace with Freeline or similar non hardening material.

1 Like

What has been changed/removed/replaced since it ran last?

Air in the lines should not prevent the pulse pump from moving fuel. May be a stuck float in the carb. If the float is stuck in up position, it will cut off any fuel flow into the carb. A quick check would be to remove the float bowl and physically check that it moves up and down freely. Next, blow into the fuel tank vent line to add some positive pressure. With the float down, fuel should flow into the carb. If it does not, may have a bad needle or connection from the float to the needle. Any air in the line will be pushed into the carb as fuel flows.

I honestly have no clue, since i got it i just bled everything and added new fluids. How do you check the float in the carb? Where is it located?

Can you upload a picture of your carb? It should look similar to this:
I saw one listed with a Dellorto Carb. I think Rotax uses the Dellorto Carbs too.

The small black square part on the bottom of the carb is the Float Bowl. You should be able to unscrew it from the carb. Carefull not to lose or pinch any of the gaskets or o-rings when re-installing. The Float will be a small plastic or hollow metal ring or cube(s) inside. It hangs from the carb body and as fuel is pumped into the Bowl, the float rises and restricts or stops fuel flow by articulating a metering needle. Typically by way of a lever or pin. I am not familiar with the Dellorto Carbs, but the basic principal is the same as the carbs most lawnmowers use.

Here is an exploded view:

1 Like

Try just removing the carb. Drain and see if fuel comes out.
Pull the spark plug after cranking to see if it is wet?

@lollo_betto are you making any headway?

Yes, that is the same carburetor I have, I will check when i can the float. Thank you, I will let you know if that was the problem.

@Richard_Jacques sorry, i have no clue what that is.