IAME X30 not starting after replacing Carb

x30

(Chris Taylor) #1

Hi All,

Hoping I can get some help regarding my X30 not starting since I have replaced my Carburetor.

Is there anything simple that can happen in this process causing the kart not to start?

I have checked the coil and it appears to be sparking correctly and I can certainly smell fuel in the combustion chamber, the fuel line also primes without issue.

I am fairly sure I have the reed pack in the correct orientation with the IAME tag on the top along with the gaskets. The gaskets look to all have dual holes to ensure the pulse signal cant be blocked so I cant really see how these could be oriented incorrectly.

The engine doesn’t even cough or splutter, it just turns over on the starter motor.

Any ideas would be appreciated.


(Johan Svahn) #2

Did you change the reed valves? If so check if the valves are the right way. IAME text should be outwards.
If the valves are damaged or the wrong way they can be the reason not making the engine start.


(Chris Taylor) #3

I didn’t change the valves, just swapped the entire reed block over to the new housing.

They look OK and if I blow a lightly through the inlet when fitted to the housing I can hear them popping open.

I did run my finger over them when they came out but they look fine so I can’t image they are that delicate.


(Eric Gunderson) #4

I may have a guess. Did you get this carb from anyone but Tillotson directly? If so, check the top plastic fuel cap on the carb. Hairline cracks often form in that top cap fairly often, and when that happens it prevents a vacuum forming in the carburetor, causing the fuel to never fill the carb and for the engine to not start.

I mention this because I have had this happen before with my KA100 and was super bewildered until I finally gave up and asked my friend for help who mentioned this was a problem on the x30 carbs.


(Chris Taylor) #5

Hi Eric,

It appears the carb is working correctly. If I cover the the inlet it certainly creates a vacuum and the fuel flows out the front of the carb. I also refitted the old carb and the Kart wont start with this fitted as well so I am thinking it is not the carb.

What else could it be? I am confident it is not spark and nothing has been touched as far as spark timing goes.

If I remove the plug I can smell fuel fumes in the cylinder but the plug does appear to be dry so the smell may just be residual. Compression seems Ok but what should the PSI reading actually be on and X30 as I haven’t been able to find this spec anywhere.

Could the read valves be causing the issue? They look ok and seem to pop open very easily.

As I said the engine is not firing at all so I am leaning to a lack of fuel.


(James McMahon) #6

Is it flooded at this point perhaps. Sometimes if the motors been sitting for a while you draw up a lot of oil from the crankcase making it hard to start.

How does the plug look?


(Chris Taylor) #7

Plug looks fine. I fitted a new plug and it is staying perfectly clean.


(James McMahon) #8

If the plug is still dry and clean, it’s not getting enough fuel. If you’ve been turning the motor over, and it’s not firing at all, the plug should be pretty wet at this point.

To make sure it’s getting plenty of fuel, sometimes they just need a good choke…

  1. If the airbox is on the carb, take it off.
  2. Lightly crack the throttle.
  3. Spin the motor over.
  4. While its spinning, cover the carb inlet, count 1…2 and take your hand off (keep it spinning with the starter).
  5. It should kick… If not, try covering the inlet again.
  6. Do this maybe three times before giving up.
  7. Pull the plug, it should be pretty soaked by now.

If not, it’s not drawing fuel to the cylinder for some reason.

Oh, @Chrisco can you update your profile to show your full name please. Thanks.


(Eric Gunderson) #9

I know it may sound crazy, but again, check that plastic top piece. I changed literally everything else on the engine, but changing that instantly solved the problem.

James is correct, sometimes those engines need a little choke to start.

If it isn’t that, James is also correct that going to a new plug and not seeing it eventually foul suggests you’re not getting fuel.

If it’s getting through the carb, but not into the cylinder, that basically leaves the reed cage system.


(Chris Taylor) #10

@Eric, I did check the plastic cover and all looks fine. Is a brand new carb purchased from a reputable store.

Having said that it had been about 2 months since I had last started the engine and after refitting the old carb the same problem remained so it may not be a carb issue.

I definitely can smell fuel fumes in the exhaust pipe so fuel my be getting into the chamber however the plug and the top of the piston does look dry. This is after 3x 5 second cranks. Priming the cab with my hand causes fuel to poor out of the inlet snout.

Could it be a ring problem? What sort of compressing should I expect? I have an auto compression tester which is giving me 25psi results which seems low.


(Andy Kutscher) #11

If that’s a good compression gauge then you don’t have enough compression. Idk what x30’s run when fresh but 25 isn’t going to be enough.

For comparison The KT100’s I run are generally not considered to be high compression motors and they run around 160 psi when fresh and we rebuild when they get to 120-130 worst case. They won’t run when compression is below 80-100.


(James McMahon) #12

That’s not unusual but…

25psi is no good. If you’re happy the gauge and reading are accurate, it’s time to take a look in the cylinder. If there’s no obvious damage at a glance, see if the ring is jammed in the groove.


(Ryan Spierowski) #13

This has got to be an electrical issues.

I had 2 IAME STATORs fail on me this year!! I was getting spark but it was weak.

start at the battery and replace the electrical parts with the stator being last to change.

im 95% sure if this thing is turning over and showing spark, but not firing, its still a smarts problem.

like I said, I’ve had it happen to me TWICE this year, once on grid and once out of the trailer.


(James McMahon) #14

One thing you can try to roughly gauge the strength of the spark is to take a plug that you’re not going to race again and open the gap to about 5mm. As well as making it harder to jump the gap, it’s easier to see.

With 25psi of compression though… if that’s what it’s pumping, something mechanical is up.


(Bryan Williams ) #15

Have you tried turning over with a good external starter. On board battery and starter could be weak. Just an idea.


(Chris Taylor) #16

So turns out it was a damaged ring and completely unrelated to me fitting a new carb. The 25PSI was unfortunately a true reading.

Thanks for all the suggestions.


(James McMahon) #17

What have you decided to do?


(Chris Taylor) #18

Looks like it just needs a piston and ring with a very slight clean up of the cylinder cover. I am now an expert at putting apart the Tillotson carby which is one upside.