Mychron 5 inaccurate

i am having issues with my mychron 5, in fact its not really been working almost a year. the problem i am finding is there are gaps in the laps, not all, but probably 50%. What i am finding is we go to the track, spend the day testing, upload the data to racestudio and when i look at the laps on the GPS map only a few actually have a complete lap. on the incomplete laps the lap time are very good, of course because your lap is 10meters shorter than everyone else… has anyone else had this issue?..

I spoke to Aim about this and they suggested not wrapping the rpm pickup around the plug, tried that no change, i complained again and they replaced the unit with a referb however its still an issues… i am thinking of moving to Alfano as it comes with a 5 year warranty. After 1 year with Mychron they are not that interested… attached is a screenshot of the full gps map… all looks good until you zoom in… anyone else got any idea why this is happening?

Is the start finish same on mychron as in real life?

Yes looks to be. i have also just had a look back to last year, 2019 infact… looks like this issue has been with me since i brought the original mychron. as mentioned in the previous post i have new refeb from aim and its still showing signs of inaccuracy. the screenshots above were from the same session (about 8 laps) the green line was the only good lap

I had a similar issue related to start finish being incorrect. In my case, correcting that fixed my problem.

Could be an issue with GPS satellite availability?

If you do a GPS lap insert with a real complete lap in RSAnalysis does it fix it?

Ah yes. Iirc that was how it was ultimately corrected. Via lap insert. I got a correct looking lap from a teammate.

unfortunately not. see attachment below. you will see lap 9 is green and 10 is red. red is a good lap, start and finish meet, green you can see it overlaps the finish line. when i do a gps inset on lap green with red. it still shows the same…

Engineer head on…anyone else you know at the same track has the same issues? Are you next to Area 51? :rofl:

Looks to me like the unit’s GPS module is up the left if yours is the only one having issues. Why did AIM replace the unit with a refurb? Assuming you bought a new unit, if they’re gonna replace the unit under warranty it should be with a new unit not refurb.

I’ve had exactly the same thing. It might be to do with satellite coverage as mine almost never gets a good lock. I get maybe half of my videos having proper telemetry data. More often than not the gps on my gopro never gets a clean lock and can’t draw track properly.

I bet there is a connection with the fact that my gopro telemetry and less frequently the mychron 5 gps acting up.

This happens across all of the tracks i visit across south of the UK (5 or 6 in total), some tracks are worse than others, maybe… GPS coverage… GPS_Nsat for the images in this post 16 to 19 and the GPS_PosAccuracy 0.930. when i first noticed this Aim replaced the GPS module in the original unit, when i saw the issue repeat they replaced it with a referb. i really like the software and the unit itself but if your data cant be trusted its not worth having. when i initially reported the issue to aim i sent them the test files and they confirmed it was GPS related but they never fixed the problem. The 5s is more accurate in terms of GPS but i am reluctant, to take a gamble, on buying a new unit as a fix for a faulty product.

I dont know what is possible with GPS, but there is an app I used once that showed that my Track was basically yellow/red sort of levels of quality of lock. Which sort of blows my mind since its near a medium sized airport and close to a major city.

I just wanted to provide some further feedback on this issue as we ran in a timed race meeting yesterday which i was able to compare against the mychron. What i found was apart from a couple of laps where the mychron really got it wrong all of the laptimes on the mychron were within hundredths of a second when compared to the race timing system which is good enough. however most of the laps within racestudio still have the problem where there is a gap in the lap. so i now know the lap times are good, but can i trust the other telemetry… . if i find a fix i will report back.

1 Like

Do you have beacon sensor as well, magnet or optical?

In the lap cause column on your lap data, its says GPS Lap Time. I’ve found sometimes this goes totally wonky and the beacon seems to be more reliable.

Now I thought you could change this after the fact in race studio but I can’t remember how. It can definitely be changed on the dash itself though. That might be worth a try.

1 Like

Is the problem that Mike have a universal issue or more isolate? It’s hard to believe that AiM would put out a product that isn’t reasonably accurate and consistent. For me gaps in data would be hard to accept and put into question any of the data.

A few years back I tried the various M4 GPS modules and at one track it was .25 seconds off and comparing one lap from one session to another, the lap overlays had to be adjusted in Race Studio, which I find disturbing, so I stopped using GPS. I find that the M4 with e-box, beacon and a speed sensor provides more consistent data but not sure of the accuracy.The one annoying issue with M4/beacons setup is the track or club isn’t real careful about whether there is a beacon out on the track.

The downside of the M4 is parts available. The back lighting failed on my M4 and AiM didn’t have the parts to fix it. The convenience of the M5 is a huge plus, bolt the dash on and it’s ready to collect data.