RaceStudio 3 tries to install on invalid drive

I tried to install RaceStudio3 on my new computer. Windows 11. When I open the installer (.exe file), it automatically tries to install program files in invalid D: drive that doesn’t exist, won’t let me select where I want to install the files. Anyone have a fix for this?

I tried installing the beta version of RS3, and it has a dropdown menu and a browse function that allows me to select the C: drive and install successfully, but it won’t download track data. It pops up a windows that says “Preparing Tracks Database” but never actually starts installing tracks even when connected to wifi.

I emailed AIM about this, but I’ll ask here too in case they don’t respond.

1 Like

I wish I had something for you on this. Anything weird with other apps you’ve installed?

No. No response yet from AIM either. I’m bummed because I wanted to analyze the new gear ratio I tried at 103rd Street this past weekend. I could still read some data off the screen on my MyChron, I suppose. I could also use RS2, but I don’t have the right cable to transfer data from my MyChron 5 2T to my computer.


I have never used a cable.

Rs2 can do wifi? I thought only RS3 had that feature.

Ahh, I assumed you could still download your data with RS3 and it was just an issue to use for analysis.

I’m not sure I understand what you mean.

It sounds like he’s able to initiate transfer fine… app hangs “looking to prepare tracks database”