Rotax Max fails to run properly


I have Rotax Max evo I’ve Been struggeling with for a while now.

I picked the engine up from a rebuild at my local sertified Rotax service station.

Since that I can not make it run clean, it stotteres, misfires and stops.
From half Open throttle to Max opening, it only stotteres, almost like 4-stroking, sometimes it can reach higher rpm but mostly it dies.

I have tried swapping all electrics, exhaust valve, carburator, vacuum Lines, Spark plug, fuel Lines and valve sensor.

The shop opened the engine again without finding any faults.

Today i tried another engine in my setup, and it runs perfekt.

I dont know what to do next, any advice?


Could it be running lean… they have a tendency to exibit that behavior when running lean (or have an air leak somewhere) Its a tough one to guess when the engine came back from the service center.

What exactly did you send to them and what testing did they do? ie was it sent with airbox, carb, boot, reed block etc?

How about the exhaust, is the packing intact?
Tacho reading stable on the gauge?

Dont think it runs lean, jetted according to the Rotax Max app.

I also ran my carb with the other engine, my cables, fuel, oil, everything was mine exept the engine itself.
Problem must be i side the engine.

Seems like it fires on every two strokes.

including the exhaust?

Yes, Even the starter engine.

I wonder if the ground to the chassis via the mount is at play.
Saw that you tried all the ancillaries on another kart, how about the entire engine complete with clamps?

Sorry, it is the other way around.
Another engine in my kart.

The not working engine has been in this chassis for 2 years.

Was working fine before the rebuild.

Did you get it figured out Tom, this one is perplexing.

Sounds like you could have a case leak. Did they do a pressure test on the case when you took it back.

This video illustrates how to pressure test the case: (skip to 6:38)

1 Like