Mychron 4 Lap Time Data Issue

Hi All, having some issues with my Mychron 4, which I got with my kart so I’m trying my best to make use of it.

I have the AIM GPS module with it with our local track set up in GPS Manager and transferred to the GPS unit.

When I turn on the MC4 it does recognize the track however, sometimes it works and records the lap times correctly. Other times I get one very long session instead of individual laps, for example my average lap time is 31s.

The first time I cross the start/finish I’d see 0:31, the second time would me 1:02, third time would 1:33 and so forth. So if I do three laps the entire session will be one lap of 1:33- rather than three 0:31 laps.

Any ideas?

Have you looked at the minimum lap time setting? I wonder if it’s set to a number above 31 seconds?

Although that wouldn’t explain the outlaw being 31.

As far as I recall, it’s set to 28 or 29s.

Also I forgot to mention, I only have one beacon set that is the start/finish line, I have no sectors set up.

1 Like

I’m pretty sure this is down to satellites in view and gps accuracy. My 5 also does the same from time to time

1 Like

Got it. Are you using a beam in conjunction with the GPS? If not, that might have to be your next move.

It usually has 11-28 satellites on the screen at our track from what I recall.

Beam? Can you clarify? Thanks

Not sure about the 4 but I think on the 5 you can interrogate gps accuracy on the downloaded data. Have a look if you can, you can see the accuracy when you cross the line maybe

Sure. You have two other options for lap times./counting s/f passes…

One is an infrared beam from a mychron beacon box, often on a tripod at the start/finish line, along with a receiver on the kart that plugs into the mychron.

Another is a magnetic strip that goes on the track. This is less common though.

Here’s what the beacon box looks like.

There’s a good chance the track already has one and you may just need the infrared receiver on your kart.


Okay so I actually have two sets of data I can reference, mine shows 1.25m average on the days the time did show correctly, the days it shows inaccurately the accuracy average is 2.51m.

For reference I have data from a next kart using a Mychron 5 and the accuracy says 0.424m average.

If you’re referencing GPS accuracy (the 1.25 or 2.51) it sounds like a lack of enough satellites. I work in the geospatial world and it takes time for a GPS receiver to ‘find’ enough satellites to get an accurate location fix. Generally, the more the merrier. By any chance, were there trees nearby when the accuracy was 2.51m? Did you turn the Mychron on and go? Just a couple of GPS related things I could think of that might affect the accuracy of the fix.

Hey David, yes GPS accuracy was referenced.

  1. It seems as I was mistaken in an above reply with my average of up to 28 satellites. For the MC4 the average is 8-13 satellites (MC5 reads up to 16 satellites at our track).

The days when I have this issue there is average 8-11 satellites available, but I’ve also seen it read correctly on other days with the same amount.

  1. Yes our track is surrounded by a lot of trees, there’s probably a 100ft radius at most and 10ft at it’s least around the track that is clear, beyond that there’s a lot of trees.

  2. No, I usually turn on the kart, MC4 powers on I wait a couple seconds to ensure that it does read what track it’s at before I drive off.

Currently my GPS module is mounted on the chrome bracket that’s between the steering column and the nose flare, see photo. Do you think an alternate placement would assist in a better reading? If not do you have any suggestions?

Also note the greenery in the back…yep that’s trees lol.

My hero 7 and 9 mostly fail at properly recording GPS. Dunno why it’s so fickle. It may be due to NJMP proximity to airport.

One question - thinking on it if my 5 does the same it does it if I’ve forgotten for example to switch it on before starting up the kart. When I start the kart it comes alive automatically, but I do find if I do that and set off right away as one does, it doesn’t get chance to initialise properly. Then it goofs up.

If I power it up then do helmet and gloves etc, by the time I’m in the kart it’s properly initialised.

Same thing happens with planes - you can’t just switch on and go, you have to wait 2-5 minutes for the gps systems to initialise and get the plane’s location pin pointed.

I think you’re setting off before it’s got you with enough accuracy. If it’s direct powered, you should be able to switch on the Mychron before you switch on the kart, as I do.

In theory. In my case, it doesn’t synch most of the time and the gps map comes out looking like a Jackson Pollock.

1 Like

Is it the synch or the refresh rate? My Garnin watch is a bit like that but it’s because the GPS refresh rate isn’t terribly quick. . It’s a sailing watch after all, doesn’t need to be.

Jackson Pollock hahaha :joy::joy::joy:

I think it has to do with airport and satellites. It’s probably a local

Nice pic! Generally you want to have the satellite antenna with the best view of the sky possible. Looks like you got that covered. If you’re getting 8-13 satellites with a good signal (high in the sky, not too close to the horizon) you should be fine. It’s when trees or buildings or other obstacles obscure the view of the horizon or you haven’t turned the unit on for awhile (or you moved some distance from where it was the last time it was on) that it could take some time for the GPS receiver to know where all the satellites should be. If a MC5 is getting a half meter accuracy, the WAAS processing (improved accuracy) is probably turned on. That’s something you might check on your unit. Hope all that is of some help!