Rotax Evo starting issues! NO spark!

Really confused here but I ran the kart a week ago for full day with no issues then took it home stripped it down and when I went to use it today it’s miss firing and spluttering, I’ve cleaned the carb fully and that’s now immaculate.

I changed the pulse pipe (not the black pipe) because it was looking bit worse for wear so I just used fuel line.

Battery is fully charged!

The kart was running and the issue got worse and now it’s not even sparking but the ignition lead is getting voltage.

Last time it did this it was the ECU but surely not again ? The ECU is only few months old and I’ve only been out twice in them months.

Any idea anyone ? Rotax max senior evo engine

Have you tried a new spark plug? Is it cold where you are?

Tried a new plug and no luck unfortunately. It’s about 12 degrees C here (normal British weather)

Make sure the cut-off wire for DD2 isn’t grounding out on something. Could’ve shifted when you took the kart apart.

Have you tried this? Take out the spark plug, connect it inside the spark plug cap, put the electrode on one of the cylinder cover screws, and hold the starter button. See if you see any spark. If so then it’s not the ignition, if not then it’s your plug or electronics.

Well I think it’s sorted! It was the DD2 wire! Bit confused because I put it back where it was so maybe I was lucky before! I’m new to the EVO Motors so still learning.

Thanks for the help guys. Much appreciated


Well I thought I sorted it but the problem still exists unfortunately! I tried someone else’s harness and it ran great until I got on the track and did exactly the same as above.

Only thing I haven’t tried is the coil ? I did notice when I took the plug out the top to see if it would spark the spark would sometimes be all over the place and not between the actual gap ?

Anyone ever had coil issues ?

I’ve uploaded this video for reference!

I am no expert but I would try these things:

1)Bad gas- remove the gas tank, dump out every drop in the tank, blow out the fuel in the fuel lines, clean out the carb of any fuel and dirt, and replace the spark plug, put fresh gas.

2)Fuel pump- try someone else’s or use a rebuild kit to make sure it functions properly.

3)Dirt in carb- take apart the carb completely, clean, and check all jet holes are clear.

4)Coil cab- remove the coil cap and squeeze it with a pliers to ensure contact is good between cap and spark plug.

5)Reeds- take the carb off and shine a light inside the reeds. Hard to check but see if you see any gaps in the pedals. It might work if you start it with the airbox off and it’s spits back at you some fuel and air. If it does, maybe the Reed pedal screws backed out, a chunk came off, or they are bent bad, have someone replace them.

  1. Coil- try someone else’s coil

  2. ECU- try someone else’s ecu

That’s about all that comes to mind.

Is there an opening in the black hose that goes from one side of the carb to the other?

Yea I have the gap in the pipe going over the carb

The fuel was a week old, I am running a in-line fuel filter ?

Carb has been cleaned out about 10 times now and no different.

Fuel pump has a new kit installed and fuel doesn’t go back

I have done what you said with the plug cap and still no difference

Have not checked reeds but didn’t spit any fuel at me thankfully haha

I’ve tried someone else’s harness and ECU and no difference.

Only thing I haven’t really tried is coil and strawberry sent me a second hand one when the first one melted somehow

Can you run through what exactly you did when you originally disassemble?

I just removed the engine from the actual chassis itself, Unplugged the harness etc and took engine off the kart.

I think this problem has been happening from the start tho and I’ve just been lucky to have days of it running fine. My local engine guy has it now and hopefully it’s just something silly that I’ve done.

I did remove the radiator because the engine builder didn’t need it on and when I removed the coolant it was a horrible colour.

The issue has been found! Unfortunately the engine had slipped a piston ring and destroyed the head and piston, also the crank sensor was bad.

Unfortunately the engine is pretty low on power but my engine guy has put a different cylinder head on and it’s now producing 29.9hp the only thing that’s the issue is when he used my exhaust on the engine it brought the power down to 29.4hp

First image shows the engine with my cylinder on then a one I’ve just bought (used)

Second image is my engine and new cylinder on but with my exhaust. So my exhaust is sapping the gains unfortunately

1 Like

Glad you got to the bottom of it. Sounds like the packing in your silencer has collapsed maybe?

I’m hoping that’s all it is but I keep hearing that exhausts differ a lot and some produce good gains

Go with James’s suggestion first. That’s your best bet. Also check the fit of your pipe to the engine. A leak may prevent the power valve from completely opening.

1 Like

So is the 0.5hp loss going from no pipe to your pipe or one of the builders pipes to your pipe?

He put a different cylinder on my engine which brought the power back up using his exhaust on his dyno, then he used my exhaust with the new cylinder and the gains were taken away because of exhaust! I’m going to repack it but will this improve the horsepower?